Why is my Pod System not firing?

There are a few reasons why your Pod System may not be firing. Below are a few troubleshooting tips that you can follow that may help resolve this issue: 

  • The device is making poor connection with the replacement pod. Please ensure the metal prongs (located where the replacement pod is inserted) are not in a depressed state. You may attempt to fix this issue by using a Q-Tip to press down the prong while moving the prong in a circular motion. This should help the prong spring back up into its original position. 
  • The battery is dead or has a poor electrical connection with the pod. 
  • Depending on the device you are using, you may need to assure the device is powered on. You may do so by pressing the fire button five times in quick succession.
  • The replacement pod and/or coil is faulty. Attempt to use a new pod and/or coil to confirm this is not the root of the issue. 
  • If the pod system has adjustable wattage, please be sure you are firing the device at the recommended wattage setting. 
  • Make sure there is no e-liquid residue on the contact pins, if so you can easily wipe it down with a paper towel or cloth. 
  • Allow the device to charge for about 2 hours before use. 
  • The device’s temperature protection is engaging because e-liquid isn’t reaching the atomizer coil.

If the issue was not resolved by the troubleshooting tips, feel free to Submit a Request below: 

returns@elementvape.com

Please note, you may be requested to provide pictures or video proof of the issue.

Was this article helpful?
1 out of 3 found this helpful
Have more questions? Submit a request